IS-IS, multiareas and frame-relay

To finish up with IS-IS for now, I’m going to go through the set up of a four router, three area IS-IS network that uses a hub and spoke frame relay network. Here is a drawing of the network:



The goal is to simply have all the addresses, including the loopbacks, appear in the routing tables of all routers.
R0 is pretty easy to set up, it is a level 1 router in area 49.0001
interface Loopback0
ip address 192.168.0.1 255.255.255.0
ip router isis
interface Ethernet0
ip address 10.50.0.1 255.255.255.0
ip router isis
isis circuit-type level-1
router isis
net 49.0001.0100.5000.0001.00
Moving on to R3, set up the basics. Note that since I’m using a multipoint frame relay setup, I have to set up frame-relay maps for clns (IP is using inverse arp)
interface Loopback0
ip address 192.168.3.1 255.255.255.0
ip router isis
!
interface Ethernet0
ip address 10.50.0.2 255.255.255.0
ip router isis
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0.1 multipoint
ip address 10.51.0.3 255.255.255.248
ip router isis
frame-relay map clns 121 broadcast
frame-relay map clns 120 broadcast
frame-relay interface-dlci 120
frame-relay interface-dlci 121
router isis
net 49.0001.0100.5000.0002.00
At this point, I’d expect R0 and R3 to be exchanging routes:
r3#show clns neighbors
System Id      Interface   SNPA                State  Holdtime  Type Protocol
r0             Et0         0060.5cf3.bb1e      Up     25        L1   IS-IS
r3#show ip route

Gateway of last resort is not set
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.50.0.0/24 is directly connected, Ethernet0
C       10.51.0.0/29 is directly connected, Serial0.1
i L1 192.168.0.0/24 [115/20] via 10.50.0.1, Ethernet0
C    192.168.3.0/24 is directly connected, Loopback0
Excellent. On to R1
interface Loopback0
ip address 192.168.1.1 255.255.255.0
ip router isis
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.102 point-to-point
ip address 10.51.0.1 255.255.255.248
ip router isis
frame-relay interface-dlci 102
isis circuit-type level-2-only
!
router isis
net 49.0002.1921.6800.1001.00
Nothing. Checking “clns neighbors” on R1 shows nothing, on R3 I see
1921.6800.1001 Se0.1       DLCI 120            Up     256       IS   ES-IS
Logs on R1 show:
3d03h: ISIS-Adj: Rec L2 IIH from DLCI 102 (Serial0.102), cir type L1L2, cir id0
3d03h: ISIS-Adj: Multi-point IIH received on point-to-point interface: ignoredH
I found IS-IS Network Types and Frame Relay Interfaces on Cisco’s site, it looks like the interface types must match.
r1:
no interface Serial0.102 point-to-point
interface Serial0.2 mult
ip address 10.51.0.1 255.255.255.248
ip router isis
frame-relay interface-dlci 102
isis circuit-type level-2-only
(Note how I had to change the subinterface number, otherwise IOS won’t let me change the interface type)
r1#show clns neighbors
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0100.5000.0002 Se0.2       DLCI 102            Init   9         L2   IS-IS
Damn. I forgot to map clns broadcasts on R1:
interface Serial0.2 mult
frame-relay map clns 102 broadcast
r1#show clns neighbors
System Id      Interface   SNPA                State  Holdtime  Type Protocol
r3             Se0.2       DLCI 102            Up     27        L2   IS-IS
Some testing:
r1#show clns neighbors
System Id      Interface   SNPA                State  Holdtime  Type Protocol
r3             Se0.2       DLCI 102            Up     27        L2   IS-IS
r1#show ip route
...
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
i L2    10.50.0.0/24 [115/20] via 10.51.0.3, Serial0.2
C       10.51.0.0/29 is directly connected, Serial0.2
i L2 192.168.0.0/24 [115/30] via 10.51.0.3, Serial0.2
C    192.168.1.0/24 is directly connected, Loopback0
i L2 192.168.3.0/24 [115/20] via 10.51.0.3, Serial0.2
r1#ping 192.168.0.1   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/52/60 ms
On R1, since it is in a different area than R0 and R3, all their routes show up as L2.
R2 is basically a duplicate of R1, so I won’t go into it here (not to mention the load on it doesn’t support IS-IS)
One thing, though, is I’d like to have R3 originate a default route:
r3:
ip route 0.0.0.0 0.0.0.0 10.50.0.253
router isis
default-information originate
It looks like only L2 routers can originate a default route, since all L1 routers should be going to an L2 router anyway. More information to follow in an update…
Updated
Yes, an L2 router connected to multiple areas sets the ATT bit in the LSP, which instructs the L1 routers to use it as a default route. This can be seen from R0’s routing table after R3 was set up in area 49.0002:
r0>show ip route
...
Gateway of last resort is 10.50.0.2 to network 0.0.0.0
...
i*L1 0.0.0.0/0 [115/10] via 10.50.0.2, Ethernet0
Cisco’s IS-IS Overview, under example 5:
A Level 1/Level 2 router that is attached to another area will set the “attached bit” in its Level 1 LSP; all the Level 1 ISs in an area will get a copy of this LSP and know where to forward packets to destinations outside the area. If the routers are running Integrated IS-IS, a default IP route will automatically be installed in the Level 1 routers pointing toward the nearest Level 1/Level 2 router that originally set the attached bit in its Level 1 LSP. A Level 1/Level 2 router that is not attached to another area can also detect that a Level 2-only neighbor is attached to another area and set the “attached bit” on behalf of this Level 2-only neighbor.
If there is more than one point to exit the area (multiple Level 2-capable routers), the closest Level 1/Level 2 router is selected based on the cost. If there are two equal cost paths then the traffic may load balance over the two paths.

i*L1 0.0.0.0/0 [115/10] via 10.50.0.2, Ethernet0
Cisco’s IS-IS Overview, under example 5:
A Level 1/Level 2 router that is attached to another area will set the “attached bit” in its Level 1 LSP; all the Level 1 ISs in an area will get a copy of this LSP and know where to forward packets to destinations outside the area. If the routers are running Integrated IS-IS, a default IP route will automatically be installed in the Level 1 routers pointing toward the nearest Level 1/Level 2 router that originally set the attached bit in its Level 1 LSP. A Level 1/Level 2 router that is not attached to another area can also detect that a Level 2-only neighbor is attached to another area and set the “attached bit” on behalf of this Level 2-only neighbor.
If there is more than one point to exit the area (multiple Level 2-capable routers), the closest Level 1/Level 2 router is selected based on the cost. If there are two equal cost paths then the traffic may load balance over the two paths.

TOP

Gateway of last resort is not set
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.50.0.0/24 is directly connected, Ethernet0
C       10.51.0.0/29 is directly connected, Serial0.1
i L1 192.168.0.0/24 [115/20] via 10.50.0.1, Ethernet0
C    192.168.3.0/24 is directly connected, Loopback0
Excellent. On to R1
interface Loopback0
ip address 192.168.1.1 255.255.255.0

TOP

Gateway of last resort is not set
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.50.0.0/24 is directly connected, Ethernet0
C       10.51.0.0/29 is directly connected, Serial0.1
i L1 192.168.0.0/24 [115/20] via 10.50.0.1, Ethernet0
C    192.168.3.0/24 is directly connected, Loopback0
Excellent. On to R1
interface Loopback0
ip address 192.168.1.1 255.255.255.0
ip router isis
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay
!

TOP

Gateway of last resort is 10.50.0.2 to network 0.0.0.0
why?

TOP

*L1 0.0.0.0/0 [115/10] via 10.50.0.2, Ethernet0
Cisco’s IS-IS Overview, under example 5:
A Level 1/Level 2 router that is attached to another area will set the “attached bit” in its Level 1 LSP; all the Level 1 ISs in an area will get a copy of this LSP and know where to forward packets to destinations outside the area. If the routers are running Integrated IS-IS, a default IP route will automatically be installed in the Level 1 routers pointing toward the nearest Level 1/Level 2 router that originally set the attached bit in its Level 1 LSP. A Level 1/Level 2 router that is not attached to another area can also detect that a Level 2-only neighbor is attached to another area and set the “attached bit” on behalf of this Level 2-only neighbor.

TOP

返回顶部
CopyRight © 2009 CCNA Live

Powered by Discuz! 7.2 © 2008 Comsenz Inc.

Contact Us - Clear Cookies - Stats - Archiver - WAP

GMT+8, 2018-10-16 03:21.